[SOLVED] CircleCi build failing after successful deploy on heroku


#1

Here follows the output from CircleCi. Everything seems right, it ran my tests and deployed successfully.

remote: Successfully installed certifi-2017.7.27.1 chardet-3.0.4 heroku-0.1.4 idna-2.6 python-dateutil-1.5 requests-2.18.4 urllib3-1.22
remote: https://gcs01-rafaelrabetti-circle.herokuapp.com/ deployed to Heroku
remote:
remote: Verifying deploy… done.
To https://git.heroku.com/gcs01-rafaelrabetti-circle.git
78d568a…2196eb8 master -> master
/bin/bash: line 2: heroku: command not found
Exited with code 127


#2

I just erased these heroku commands below from my config.yml file. Not the best solution, but it works now.

  - deploy:
      name: Deploy Master to Heroku
      command: |
        if [ "${CIRCLE_BRANCH}" == "master" ]; then
          git push heroku master
          **heroku run python manage.py deploy**
          **heroku restart**
        fi

#3

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.