Silent failure when using workflows


#1

TL;DR I’m getting no new builds on CircleCI after adding workflows to my YAML config.

Hey,

Firstly, congrats to the CircleCI team on the release of workflows :raised_hands:. As soon as I saw the blog post I wanted to give it a go - and so my troubles begin… Basically, after adding workflows, I’m getting no new builds on CircleCI.

I’ve been using circle for a while now and have a pretty solid understanding of the 2.0 configuration. When adding workflows, I followed the doc carefully (https://circleci.com/docs/2.0/workflows).
I’d also checked my YAML is valid here (https://codebeautify.org/yaml-validator)
I tried the running the CircleCI CLI tool on it - no complaints (although it only did run the first job in my list? does the CLI support workflows?)
Finally, for sanity I checked that my webhooks were okay between BitBucket and CircleCI - no issues there either.

I can privately share my config.yaml on request.

Any help would be muchos appreciado.


#3

Sorry that you are having issues. Please send us an email at beta+workflows@circleci.com


#4

You have an invalid configuration. If you were to share your Workflows snippet, it likely has an indentation issue next to requires.

It should look like this - note the additional indents before requires:

version: 2.0
jobs:
  - build:
      machine:
        enabled: true
      steps:
        - type: checkout
        - type: shell
          name: Say Hello
          command: |
            echo "Hello There"
  - test:
      steps:
        - type: shell
          name: Say Goodbye
          command: |
            echo "Hello Goodbye"

workflows:
  version: 2.0
  build-and-test:
    - build
    - test:
        requires:
          - build

#5

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.