Rspec: --exclude-pattern not working

rspec

#1

Hi guys,

It looks like the --exclude-pattern option in my .rspec file has been ignored.

--exclude-pattern spec/api/{controller,grape}/**/*_spec.rb

From the console I can see that the option has actually been included but the test still runs on the supposedly excluded files.


#2

We have this working in rspec tests. The only difference in our case is we’re using double quotes around the pattern:

–exclude-pattern “spec/api/{controller,grape}/**/*_spec.rb”


#3