Python 3.6.2 in machine executor?

python

#1

Can Python 3.6.2 be added to the pyenv used in the machine executor?


#2

I’m also interested in getting this.

This is likely as simple as updating the image used for the machine by updating pyenv.


#3

Is there an ETA on when this will be fixed? I’m currently using version 1.0 because 3.6.2 comes out of the box as a specifiable version. On 2.0 this isn’t the case. The highest it goes is 3.5.2 when using pyenv. Installing 3.6.2 with pyenv install 3.6.2 takes a while as well.


#4

I opened a PR.

https://github.com/circleci/image-builder/pull/137


#5