Preinstall QT5 in images

shipped
qt5

#1

A lot of tools are switching to QT5 so it would be cool to have QT5 preinstalled.

The current solution adds roughly 1 minute to each build.


#2

Thank you for your suggestion, we’ll see if we can pre-install it in one of the next container releases.


#3

Hi all, I’d really appreciate Qt5 preinstall as well.

Qt5 has been incredibly faster than Qt4. We’ve seen a 4/5min build finish in 1min30s with Qt5. And I haven’t seen any relevant issues so far.

cheers


#4

+1

Qt5 is faster and would prevent warnings like the following when using capybara-webkit:

WARNING: The next major version of capybara-webkit will require at least version 5.0 of Qt. You’re using version 4.8.7.


#5

Hi all, I’d really appreciate Qt5 preinstall as well.


#6

I would also like this feature. I’m getting a lot of crashes in capybara-webkit which seem to be fixed in qt5


#7

+1 I’d love to see containers with QT5


#8

Hi, we’d really appreciate this feature as well. Thanks.


#9

We would also like to have qt5 preinstalled.


#10

FYI Now preinstalled on Ubuntu 14.04 (trusty): Ubuntu 14.04 (Trusty) container However there are issues: Using Qt 5 with CircleCI


#11

capybara-webkit is starting to have issues running on Qt4 and will be dropping support for it very soon https://github.com/thoughtbot/capybara-webkit/issues/909


#12

QT5 is now pre-installed in our Trusty image. We will not be backporting it to our 12.04 image, so if you need to use QT5 please use Trusty.

Trusty (followed by Xenial) is our primary focus right now. If you are having issues with QT on Trusty please let us know so that we can address each problem.


#13

Unfortunately the version pre-installed causes memory issues as described in this other thread: Containers running out of memory on 14.04 image but runs fine on 12.04
Could QT5.5 be the version preinstall instead?
Thanks


#14