PHP version 5.6 on 7.* image

php
php7.1

#1

Attempting to use one of the many PHP 7 images listed here:
https://circleci.com/docs/2.0/circleci-images/#php

Builds fail at the “Composer Install” step due to errors like:
requires php ~7.1 -> your PHP version (5.6.17) does not satisfy that requirement

When I ssh in, php -v returns 5.6.17. Is there another step I’m missing to enable php 7.* on one of these images?

I’ve tried stripping the circle.yml file right back during debugging:

version: 2
jobs:
  build:
    docker:
      - image: circleci/php:7.1-cli

#2

Misnamed config file which should have been .circleci/config.yml not .circleci/circle.yml :slight_smile:


#3

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.