OSX Containers can't specify ruby version

ios
osx
bundler
ruby

#1

The default version of ruby that comes with an OSX Container with Xcode 7.3.1 comes with ruby version 2.0.0; which isn’t that great for gems (such as fastlane that’s commonly used with iOS/Xcode builds) that have dependencies that require ruby 2.2.2 or higher.

The docs mention that our ruby version is inferred from our .ruby-version file:
https://circleci.com/docs/unrecognized-ruby-version/

It seems however, that this only works for Linux builds; and as a result I’ve had to resort to installing rbenv and the correct version of ruby myself manually after the machine is setup - therefore costing us a few extra minutes per build.

It would be good if as a part of the circle.yml we could set the ruby version of OSX containers. Or even better - it could be inferred by the .ruby-version file at the root of our projects like how it works for Linux containers.

Joshua


#2

upvote, causing build errors using cocoapods 0.39 and ruby 2.3.0, which seems to be the new default


#3