Meteor Circle CI browser testing

nodejs
circle.yml

#1

Hi -

My tests work fine on circle 1.0 config… any ideas why its not working on 2.0 config?

When it runs the test it gives me this error -

[Error: Selenium server did not start.Another Selenium process may already be running or your java version may be out of date.]

i’ve tried installing java… logged in with ssh… there is nothing else running on 4444 port, java is installed… some im not sure whats wrong.

Here is my 1.0 config

machine:
  node:
    version: 4.6.2
dependencies:
  pre:
    - echo $METEOR_SETTINGS > settings.json
    - echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p
  cache_directories:
    - "~/.npm"
    - "~/.meteor"
    - "node_modules"
    - "./.meteor/local/build"
    - "./.meteor/local/bundler-cache"
    - "./.meteor/local/isopacks"
    - "./.meteor/local/plugin-cache"
    - "/opt/circleci/nodejs/v4.6.2/bin"
    - "/opt/circleci/nodejs/v4.6.2/lib/node_modules"
  override:
    - ./.testing/upgrade_chrome_version.sh
    - ./.testing/cache_meteor.sh
    - ./.testing/cache_npm_dependencies.sh
    - ./.testing/cache_build_and_dependencies.sh
checkout:
  post:
    - git submodule update --init
test:
  override:
    - case $CIRCLE_NODE_INDEX in 0) meteor npm test ;; 1) ./tests/acceptance_run ;; esac:
        parallel: true

Here is my 2.0 config

version: 2
jobs:
  build:
    working_directory: ~/newkeyz
    docker:
      - image: circleci/node:4.8.3-browsers
        environment:
          _JAVA_OPTIONS: "-Xms512m -Xmx1024m"
      - image: selenium/standalone-chrome-debug
      - image: mongo:3.4.4
    steps:
      - checkout
      - restore_cache:
          name: Restore Meteor Cache
          key: meteor-cache-{{ checksum ".meteor/release" }}
      - restore_cache:
          name : Restore NPM Cache
          key: npm-cache-{{ checksum "package.json" }}
      - restore_cache:
          name: Restore Meteor Package Cache
          key: packages-cache-{{ checksum ".meteor/versions" }}
      - run: sudo sed -i -e 's/# en_US.UTF-8 UTF-8/en_US.UTF-8 UTF-8/' /etc/locale.gen &&    sudo dpkg-reconfigure --frontend=noninteractive locales
      - run: sudo apt-get install default-jdk
      - run:
          name: Create Settings File
          command: echo $METEOR_SETTINGS > settings.json
      - run: ./.testing/cache_meteor.sh
      - save_cache:
          name: Save Meteor Cache
          key: meteor-cache-{{ checksum ".meteor/release" }}
          paths:
            - '~/.meteor'
      - run: meteor npm install
      - run: ./.testing/cache_npm_dependencies.sh
      - save_cache:
          name: Save NPM Cache
          key: npm-cache-{{ checksum "package.json" }}
          paths:
            - '~/.npm'
            - 'node_modules'
      - run:
          name: Run Test
          command: ./tests/acceptance_run
      - save_cache:
          key: packages-cache-{{ checksum ".meteor/versions" }}
          paths:
            - './.meteor/local/build'
            - './.meteor/local/bundler-cache'
            - './.meteor/local/isopacks'
            - './.meteor/local/plugin-cache'


#2

any insights folks?


#3

Can you try removing - image: selenium/standalone-chrome-debug


#4

Hi tom - I’ve tried that too -

https://circleci.com/gh/port80labs/newkeyz/524#config/containers/0


#5

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.