Jest Test Output Color Lost


#1

Since converting a project to 2.0, we’ve lost our test output color which our devs use to more easily comb through test runs.

Build image: node:6.10

Example test step:

- run:
    name: Unit tests
    command: |
        if ! [ $CIRCLE_TAG ]; then yarn run test:ci; fi

Which, from package.json, runs:
"test:ci": "NODE_ENV=test jest --coverage --maxWorkers 2"

We’ve seen correct colored output in CircleCI 1.0. I’ve also tested locally from the node:6.10 image, where I see the colored output as well. I’m hoping this is a simple bash setting that I’m missing, but we’d love to get back to seeing our test output with pretty colors!


#2

We solved this by adding --colors param to command, see:


#3

Just an FYI jest set’s NODE_ENV=test automatically, no need to do so :wink:


#4