How to update npm version?

npm

#1

First all, say I’m newbie with CircleCI.

When I make a push, when test are running, I got this error and it stops:

To use this template, you must update following to modules:
npm: 2.14.12 should be >= 3.0.0 

Of course, in my local environment works.
Here is my full report build link

This is my .circleci/config.yaml file:

version: 2
jobs:
  build:
    docker:
      - image: circleci/node:latest

    working_directory: ~/repo

    steps:
      - checkout

      - restore_cache:
          keys:
          - v1-dependencies-{{ checksum "package.json" }}
          - v1-dependencies-

      - run: npm install

      - save_cache:
          paths:
            - node_modules
          key: v1-dependencies-{{ checksum "package.json" }}

      - run: npm test

And here is a link to my package.json file : package.json

Any advice? I have been trying with some others configurations, but it’s not working.


#2

It’s the file name, it should be .yml instead .yaml :tired_face:

(How can I close this topic?)


#3