`git config ...` not accepted as string to `run` command

github
git
cci-20

#1

I’m using the following line to ssh into GHE instead of https:
- run: git config --global url.git+ssh://git@git.corp.my_company.com.insteadOf git://git.corp.my_company.com

However, I get the following error upon spinning up the environment:

  • In step 10 definition: Invalid step structure (expected string or map, got config.StepDescription)

I don’t know why the git config command is not taken as a string, especially since the same command works on other repositories I’ve worked with…

I run this command before “- checkout” and after an “add_ssh_key” command. Any advice for why this might be happening?


#2

Could you change the formatting of your question to use block formatting rather than inline code formatting? It would be necessary for readers to see if the line breaks here are a result of wrapping, or are actually in your config file.


#3

It turned out that I was mistaken as to the cause of my error. The error message was misleading me to think that the config line was at fault, when it was really erroring on the later “store_test_results” step.


#4

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.