Connection refused! Is selenium server started?

selenium
circle.yml

#1

Hello, I have this errors when trying to run e2e tests

Starting selenium server... started - PID:  3547

[Test] Test Suite
=====================

Running:  default e2e tests

Error retrieving a new session from the selenium server

Connection refused! Is selenium server started?
{ state: 'unknown error',
  sessionId: null,
  hCode: 1410043077,
  value: 
   { localizedMessage: null,
     cause: null,
     suppressed: [],
     message: null,
     hCode: 1396471512,
     class: 'java.util.concurrent.TimeoutException',
     screen: null },
  class: 'org.openqa.selenium.remote.Response',
  status: 13 }

I dont know why, as you can see, selenium server is started.

This is my config file:

version: 2
jobs:
  build:
    docker:
      - image: circleci/node:6.11

    working_directory: ~/repo

    steps:
      - checkout

      - restore_cache:
          keys:
          - v1-dependencies-{{ checksum "package.json" }}
          - v1-dependencies-

      - run: npm install

      - save_cache:
          paths:
            - node_modules
          key: v1-dependencies-{{ checksum "package.json" }}

      # this solves java/jdk not installed problems 
      - run: echo "deb http://http.debian.net/debian jessie-backports main" | sudo tee --append /etc/apt/sources.list
      - run: sudo apt-get update
      - run: sudo apt-get install -t jessie-backports openjdk-8-jdk

      # run tests!
      - run: npm test

Any idea? Thanks


#2

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.