Cocoapods cache breaks build. Need to build without cache

cache
cocoapods

#1

I’m having an issue with my builds. Circle is caching the cocoapods directory, but we just started checking in the cocoapods to our ios repo. When the builds run, I get an error from the cocoapods lockfile check (one of Xcodes build steps) that they are out of sync with their lock file. When I rebuild without cache everything works fine. Circle’s docs say that as soon as a build after clearing the cache works the cache is reset but in this case, it worked and then it stopped working again.


#2

Have a look at: https://circleci.com/docs/how-cache-works/#clearing-the-cache


#3

@mastilver I tried that approach but was unable to get it to work. It seems that the repo is pulled before the cache is applied. In that case, deleting the pods directory won’t work because no step after this will re-create it. I needed a way to delete the cache before the repo was cloned. Fortunately, CircleCI has the tools to do this on their end, and they were able to delete the cache.

Still, I’m very surprised that there is no button to simply delete the cache manually.

Thanks for your help!


#4