Cannot checkout anymore

Hi, since this morning, I cannot run the checkout step anymore. I did not change anything on my config, and all the projects of my organisation are now failing on checkout with the following error :

Directory (/home/circleci/project) you are trying to checkout to is not empty and not a git repository

I tried to rotate the GH access following the CCI recomandation due to the Security Alert of the 7 January, but it’s not helping me.

Do you have any idea of what I can try to solve that error, or where I can investigate ?

1 Like

I’m also having this issue, no matter what I do, it’s broken.

Even after removing cache, re-authorizing it, etc, still broken:

“you are trying to checkout to is not empty and not a git repository”

Can anyone from CircleCI comment on this? I’m about to look for another CI solution, we have been paying thousands of dollars, zero support on this issue.

It’s so maddening that CircleCI doesn’t even monitor these discussions.

1 Like

Same here. Just started today, no changes in config from yesterday.

Ok guys, I just found the solution !!
As It’s logged nowhere the fail is coming from a library update :exploding_head:

In my case, it was the browser-tools that I had to update to the last version 1.4.0

And the other thing I had to do is put the checkout step first in the steps (don’t ask me why but it’s now required :man_shrugging:)

I hope it can help you to fix this bug !

If it’s not, my advice is to remove all your custom configurations until it compile successfully, then add it back step by step


In my case, we also had browser-tools installing before checkout in the steps list, but weren’t specifying a version. Moving checkout to the top was all I needed to do to get my build running again. Thank you @JamJacques for the assist!

1 Like

Our project already specified browser-tools v1.4.0, so I’m not even sure that a change there was the issue. But like @unixmonkey, moving the checkout step above the browser install steps seems to have fixed it.

1 Like

This issue is being tracked here: LICENSE.chromedriver placed in project dir, preventing checkout · Issue #62 · CircleCI-Public/browser-tools-orb · GitHub

I’ve been using the browser-tools orb (CircleCI Developer Hub - circleci/browser-tools) for a while with the following steps (first steps in my build job):

  - browser-tools/install-chrome
  - browser-tools/install-chromedriver

However today they are both causing problems. install-chrome fails with :

E: Failed to fetch  404  Not Found [IP: 80]
E: Failed to fetch 

4ubuntu3.17_amd64.deb 404 Not Found [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

adding a step before fixes this:

  - run: sudo apt-get update

But then install-chromedriver fails because it leaves behind a license file in my working directory

adding a step after fixes this:

  - run: sudo rm -fR ~/MYWORKINGDIRECTORY/*

These both feel like workarounds – shouldn’t the orb work out of the box?

May be as workaround you can hardcode the last google chrome version which worked for you until orb things works out of the box

  • browser-tools/install-chrome:
    chrome-version: “108.0.5359.124”

v1.4.1 of the orb has been released with a fix for this issue.


Thanks! I’m just catching up with all this and was running into this issue with browser-tools 1.4.0.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.