All builds failing


#1

All our builds starting this morning have been failing (on circle2). Our image installs mongo db and starts it as an entrypoint and I ran the image locally and the database is running.

However, it looks like circle is having issues connecting to the db locally on the image and failing all the tests.

https://circleci.com/gh/askspoke/spoke/6652


#2

I see a lot of errors about missing env vars. Which database are you trying to run? Does changing those env vars change anything?


#3

I am running mongod on the image as an entrypoint. The env vars are not related to the database issue.


#4

I also just ran the image locally, and tried to run the tests and it worked. However, even locally, the same thing fails when I use circleci-builder. Could it be that for some reason circle is not either a) respecting the entrypoint, or b) not able to find the mongo server?


#5

Can you try initiating Mongo manually as a background process? Seems like the entrypoint is being ignored. We did roll out a change this morning to overwrite the cmd of an image to prevent the build from failing silently; this could be related.


#6